summaryrefslogtreecommitdiff
path: root/x11-libs/libICE/libICE-1.0.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libICE/libICE-1.0.10-r1.ebuild')
-rw-r--r--x11-libs/libICE/libICE-1.0.10-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libICE/libICE-1.0.10-r1.ebuild b/x11-libs/libICE/libICE-1.0.10-r1.ebuild
new file mode 100644
index 000000000000..8375f1dbefdd
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.10-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+DEPEND="x11-base/xorg-proto
+ x11-libs/xtrans"
+RDEPEND="${DEPEND}
+ elibc_glibc? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ --disable-docs
+ --disable-specs
+ --without-fop
+ )
+ xorg-3_src_configure
+}