summaryrefslogtreecommitdiff
path: root/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild')
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild
new file mode 100644
index 000000000000..6bf8e5f4facb
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GNOME_ORG_MODULE="vte"
+
+inherit gnome2
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+# gnome-pty-helper is inside vte
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+
+src_prepare() {
+ # As recommended by upstream (/usr/libexec/${PN} is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+ gnome2_src_prepare
+}