summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
new file mode 100644
index 000000000000..7f490f56e3d7
--- /dev/null
+++ b/x11-drivers/xf86-video-r128/xf86-video-r128-6.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_DRI=dri
+
+inherit flag-o-matic xorg-2
+
+DESCRIPTION="ATI Rage128 video driver"
+
+KEYWORDS="~alpha amd64 ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ )
+}
+
+src_configure() {
+ # always use C11 semantics
+ append-cflags -std=gnu11
+
+ xorg-2_src_configure
+}