summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild50
1 files changed, 39 insertions, 11 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 90a061997083..f3cb6236644a 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,23 +1,51 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-XORG_DRI="always"
-inherit xorg-2
+EAPI=7
-if [[ ${PV} == 9999* ]]; then
- SRC_URI=""
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-video-amdgpu.git"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
-DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
+ x11-libs/libpciaccess
+ x11-base/xorg-server[glamor(-),-minimal]
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+"
-RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-base/xorg-server[glamor(-)]"
-DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
src_configure() {
- XORG_CONFIGURE_OPTIONS="--enable-glamor"
- xorg-2_src_configure
+ local econfargs=(
+ --enable-glamor
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}