summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild
index 7e47777406d4..877e000a1319 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.1.0.ebuild
@@ -13,11 +13,17 @@ fi
DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+IUSE="udev"
+
RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-base/xorg-server[glamor(-)]"
+ x11-base/xorg-server[glamor(-)]
+ udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}"
src_configure() {
- XORG_CONFIGURE_OPTIONS="--enable-glamor"
+ XORG_CONFIGURE_OPTIONS=(
+ --enable-glamor
+ $(use_enable udev)
+ )
xorg-2_src_configure
}