summaryrefslogtreecommitdiff
path: root/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
index b3f86cbf8a6e..27bc1f65bc9b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
@@ -22,7 +22,7 @@ S="${WORKDIR}"
LICENSE="NVIDIA-r2 BSD BSD-2 GPL-2 MIT"
SLOT="0/${PV%%.*}"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
IUSE="+X abi_x86_32 abi_x86_64 +driver persistenced static-libs +tools"
COMMON_DEPEND="
@@ -250,9 +250,22 @@ src_install() {
local DISABLE_AUTOFORMATTING=yes
local DOC_CONTENTS="\
Trusted users should be in the 'video' group to use NVIDIA devices.
-You can add yourself by using: gpasswd -a my-user video
-
-See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options.\
+You can add yourself by using: gpasswd -a my-user video\
+$(usex driver "
+
+Like all out-of-tree kernel modules, it is necessary to rebuild
+${PN} after upgrading or rebuilding the Linux kernel
+by for example running \`emerge @module-rebuild\`. Alternatively,
+if using a distribution kernel (sys-kernel/gentoo-kernel{,-bin}),
+this can be automated by setting USE=dist-kernel globally.
+
+Loaded kernel modules also must not mismatch with the installed
+${PN} version (excluding -r revision), meaning should
+ensure \`eselect kernel list\` points to the kernel that will be
+booted before building and preferably reboot after upgrading
+${PN} (the ebuild will emit a warning if mismatching).
+
+See '${EPREFIX}/etc/modprobe.d/nvidia.conf' for modules options." '')\
$(use amd64 && usex abi_x86_32 '' "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
@@ -407,20 +420,4 @@ pkg_postinst() {
elog "use nvidia-drivers for acceleration without it (e.g. commonly used"
elog "with app-emulation/wine-* or steam). Re-enable if needed."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 390.143 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}