summaryrefslogtreecommitdiff
path: root/x11-apps/xwarppointer/xwarppointer-1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xwarppointer/xwarppointer-1-r2.ebuild')
-rw-r--r--x11-apps/xwarppointer/xwarppointer-1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-apps/xwarppointer/xwarppointer-1-r2.ebuild b/x11-apps/xwarppointer/xwarppointer-1-r2.ebuild
new file mode 100644
index 000000000000..6bd47e64aada
--- /dev/null
+++ b/x11-apps/xwarppointer/xwarppointer-1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Program to move the mouse cursor"
+HOMEPAGE="http://www.ishiboo.com/~nirva/Projects/xwarppointer/"
+SRC_URI="http://www.ishiboo.com/~nirva/Projects/xwarppointer/${PN}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|^X11HOME=.*|X11HOME=/usr/X11R6|' \
+ -e 's|^CFLAGS=|CFLAGS+=|' \
+ -e 's| -o | $(LDFLAGS)&|' \
+ || die 'setting X11HOME failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README
+}