summaryrefslogtreecommitdiff
path: root/x11-apps/xrestop/xrestop-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xrestop/xrestop-0.6.ebuild')
-rw-r--r--x11-apps/xrestop/xrestop-0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-apps/xrestop/xrestop-0.6.ebuild b/x11-apps/xrestop/xrestop-0.6.ebuild
new file mode 100644
index 000000000000..619b7b5fd6d9
--- /dev/null
+++ b/x11-apps/xrestop/xrestop-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xrestop"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"