summaryrefslogtreecommitdiff
path: root/x11-apps/xlsfonts
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xlsfonts')
-rw-r--r--x11-apps/xlsfonts/Manifest2
-rw-r--r--x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch66
-rw-r--r--x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild19
3 files changed, 87 insertions, 0 deletions
diff --git a/x11-apps/xlsfonts/Manifest b/x11-apps/xlsfonts/Manifest
index 0059fac5e79d..bcb7979d3dca 100644
--- a/x11-apps/xlsfonts/Manifest
+++ b/x11-apps/xlsfonts/Manifest
@@ -1,3 +1,5 @@
+AUX xlsfonts-1.0.7-c99.patch 1977 BLAKE2B d5ea871a65ac98b3824abadb908c143a650203329dea71f85ccde658e7ab659d75161f78b371fa63277546984ba7c4831e1b61936b9b1b118a34509e3d5e7422 SHA512 0509888df5df180ae6110746ec0c01c5ffcec39c8f8bee4284eb6b68daf040456e25964f81755689bed2d8e18a41c4e0cb7a6ac1054a1b6d31549fe983869a68
DIST xlsfonts-1.0.7.tar.xz 126888 BLAKE2B 13f2e2007c38f7d1724e6ffd0c7fe9a3b887a150f50107b892327c3620e4ffdbd4ae1191a9764cc4000d6422fe0f331dcbef11c0b50013ff2d94b699c0cba1ee SHA512 ec82be0a97500a9e64fb5a6adbbec470b249b1267c3081c2bd44cd3e7148107517d1234c1da2f81b0405230ab03ad2943ea53756c3380f4d561665b38d0cedc0
+EBUILD xlsfonts-1.0.7-r1.ebuild 430 BLAKE2B 394277360cb6f7270edec83bd0971e2ce8a157076e64176e627b6dd51fe675dc4140b947ac93515a6e03b20ac08afd5f896b23a8b6d92e6e0b65057c1b1c06e8 SHA512 d1f0ee536b13f48c3b273b15024c954ca3ad0ea4a49059d1b79b2e8c79dc9589629178bdfc1d9ac18b7d0f569054b1aae9525c3d37b617f6ed7e40596372f0b1
EBUILD xlsfonts-1.0.7.ebuild 374 BLAKE2B 1f0b35c19a7eb3fd8ff305e7bbecfc3d134aa4868232a2f6524520b3e4c01500ea9bafc0268be6f53bfb92c0af5e20db63a0686da215791d039f0030ab59d55a SHA512 ec42309ee7029474c86c96347d39a7871cdb8c71ec8877e0553a53022ea6691b98d2d82007161741aa12e225e24ff7c8595e1cd5425bed2e56f0d87f898656be
MISC metadata.xml 339 BLAKE2B 74d5aa130fe25b67c3e40ff2701c5c73a65abf68021cde0cdda962614636e53a519109c21ba05df8282a10e1bcd05f0a03d1bf1722c5f107d8ecdac954b975ac SHA512 88d098e3081965ed422be6b64d4a96389c1461fdaa21d1180bf91f36e8da2fcaa6c37b23b884b887a5371decc40b225e8d9942e0aabb69e5f9ab42a7082ffa36
diff --git a/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch b/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch
new file mode 100644
index 000000000000..55b767bb6a26
--- /dev/null
+++ b/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch
@@ -0,0 +1,66 @@
+https://bugs.gentoo.org/919204
+https://gitlab.freedesktop.org/xorg/app/xlsfonts/-/issues/1
+https://gitlab.freedesktop.org/xorg/app/xlsfonts/-/merge_requests/6
+
+From c92bb3e8243773535cecc4f347437a59d01dbfef Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Tue, 5 Dec 2023 15:41:28 -0800
+Subject: [PATCH 2/2] Fix -Wincompatible-pointer-types warning from gcc (issue
+ #1)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+xlsfonts.c: In function ‘get_list’:
+xlsfonts.c:204:23: warning: assignment to ‘char **’ from incompatible
+ pointer type ‘const char **’ [-Wincompatible-pointer-types]
+ 204 | fonts = &pattern;
+ | ^
+
+Closes: #1
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+ xlsfonts.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/xlsfonts.c b/xlsfonts.c
+index b834637..39aba13 100644
+--- a/xlsfonts.c
++++ b/xlsfonts.c
+@@ -56,6 +56,7 @@ static int long_list = L_SHORT;
+ static int nnames = N_START;
+ static int font_cnt = 0;
+ static int min_max;
++static char wild_string[] = "*";
+
+ typedef struct {
+ char *name;
+@@ -65,7 +66,7 @@ typedef struct {
+ static FontList *font_list = NULL;
+
+ /* Local prototypes */
+-static void get_list(const char *pattern);
++static void get_list(char *pattern);
+ static int compare(const void *arg1, const void *arg2);
+ static void show_fonts(void);
+ static void copy_number(char **pp1, char **pp2, int n1, int n2);
+@@ -180,7 +181,7 @@ main(int argc, char **argv)
+ }
+
+ if (argcnt == 0)
+- get_list("*");
++ get_list(wild_string);
+
+ show_fonts();
+
+@@ -189,7 +190,7 @@ main(int argc, char **argv)
+ }
+
+ static void
+-get_list(const char *pattern)
++get_list(char *pattern)
+ {
+ int available = nnames + 1, i;
+ char **fonts;
+--
+GitLab
diff --git a/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild b/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..8964da7f9ca4
--- /dev/null
+++ b/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xlsfonts application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-c99.patch
+)