summaryrefslogtreecommitdiff
path: root/x11-apps/xisxwayland
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xisxwayland')
-rw-r--r--x11-apps/xisxwayland/Manifest4
-rw-r--r--x11-apps/xisxwayland/metadata.xml8
-rw-r--r--x11-apps/xisxwayland/xisxwayland-1.ebuild30
-rw-r--r--x11-apps/xisxwayland/xisxwayland-9999.ebuild30
4 files changed, 72 insertions, 0 deletions
diff --git a/x11-apps/xisxwayland/Manifest b/x11-apps/xisxwayland/Manifest
new file mode 100644
index 000000000000..362a0ff0ec61
--- /dev/null
+++ b/x11-apps/xisxwayland/Manifest
@@ -0,0 +1,4 @@
+DIST xisxwayland-1.tar.xz 4168 BLAKE2B a8e4a658427f5b03e3d05b25772c4f136c13be47a68619a6beab3db72a70e836e495fcbc8a19d5f9347f3336a1dc9b353f483fb75e47ebfdbb9b8409e63444f0 SHA512 9514442313cff4df0c71fed445ba0e3fe52f3c84ebbec81725a590f68cc42ea01ac96b23736a0108fe206da3aee48434c5c30d1c58905bfc75db35205c288bca
+EBUILD xisxwayland-1.ebuild 658 BLAKE2B efc940d5ec87691440cb8996569402b4384c3a549b410e099a11fa73ed288c5853afdd2cdb2363f15d28c093cd73847787930ecb1fe268ef35893c36e6c5cc69 SHA512 e859e3c45b9cd3260a12fccbf569cac1e0a7d9287fa474d4a5c20eaaccd0dfa3c2d7a5845055ef527d9b9d5cdb77ff1024b6957fd967e6f7ff1c78995d793170
+EBUILD xisxwayland-9999.ebuild 658 BLAKE2B efc940d5ec87691440cb8996569402b4384c3a549b410e099a11fa73ed288c5853afdd2cdb2363f15d28c093cd73847787930ecb1fe268ef35893c36e6c5cc69 SHA512 e859e3c45b9cd3260a12fccbf569cac1e0a7d9287fa474d4a5c20eaaccd0dfa3c2d7a5845055ef527d9b9d5cdb77ff1024b6957fd967e6f7ff1c78995d793170
+MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-apps/xisxwayland/metadata.xml b/x11-apps/xisxwayland/metadata.xml
new file mode 100644
index 000000000000..e943b72b8a48
--- /dev/null
+++ b/x11-apps/xisxwayland/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-apps/xisxwayland/xisxwayland-1.ebuild b/x11-apps/xisxwayland/xisxwayland-1.ebuild
new file mode 100644
index 000000000000..9ecc6cb03fe4
--- /dev/null
+++ b/x11-apps/xisxwayland/xisxwayland-1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
diff --git a/x11-apps/xisxwayland/xisxwayland-9999.ebuild b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
new file mode 100644
index 000000000000..9ecc6cb03fe4
--- /dev/null
+++ b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"