summaryrefslogtreecommitdiff
path: root/x11-apps/xinit/xinit-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xinit/xinit-1.4.1.ebuild')
-rw-r--r--x11-apps/xinit/xinit-1.4.1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-apps/xinit/xinit-1.4.1.ebuild b/x11-apps/xinit/xinit-1.4.1.ebuild
index 70f4ab1c68ae..ae32ff253c54 100644
--- a/x11-apps/xinit/xinit-1.4.1.ebuild
+++ b/x11-apps/xinit/xinit-1.4.1.ebuild
@@ -8,11 +8,10 @@ inherit xorg-3
DESCRIPTION="X Window System initializer"
LICENSE="${LICENSE} GPL-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~arm-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~arm-linux ~x86-linux"
IUSE="twm"
RDEPEND="
- !<x11-base/xorg-server-1.8.0
x11-apps/xauth
x11-libs/libX11
"
@@ -53,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- if ! has_version 'x11-apps/xinit'; then
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
ewarn "any executable. When you run startx, it will run this as the login session."
@@ -64,11 +63,13 @@ pkg_postinst() {
ewarn " env-update && source /etc/profile"
fi
- if has_version "<${CATEGORY}/${PN}-1.4.1"; then
- ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
- ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
- ewarn "is transparent for most of users, however those that use runtime temporary"
- ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
- ewarn "not to remove the 'serverauth.*' files."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+ done
}