summaryrefslogtreecommitdiff
path: root/x11-apps/xauth
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/Manifest3
-rw-r--r--x11-apps/xauth/xauth-1.1.3.ebuild22
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild29
3 files changed, 24 insertions, 30 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index 04c433220802..106e7e571d3c 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1,4 +1,5 @@
DIST xauth-1.1.2.tar.xz 156960 BLAKE2B 2ba168229bdf0c1d0fdd4c352e434abfc6f527cbafce35abac8d403a0dea91f00fd858f91f177128d13a0e618d1d95061c71ef32a3e12ac91b72a257dcfcd12b SHA512 ac23fcd166b45abf7b030994ff3332c9906023dc1ddfa9b9d3000e6a914dc5e0213c4a2aa409cb3ddb93e1f9f4f6374376109241a95ef8c36af842de1f6f76e8
+DIST xauth-1.1.3.tar.xz 159500 BLAKE2B 6acc6f360b7ed947d5dbc0b197b7ed0a87916f38cd8a0c74215b96ca44e98ead45987614e88833b0d2a957776b6e6a1d69d1a3dc4563774e451c2d5f5c55394d SHA512 536434f6c607673c00b9658ea591bf32419cc151d138f991ea38167220563519a6a84a5504003da15820f2a7ed50ea2449c6ce9c991d1446ee9a7305c647d694
EBUILD xauth-1.1.2.ebuild 579 BLAKE2B d55c98e00d10c1eb227a52aa5af0fbb95abdb51946a58f61750cf1f9e754fbf93badb4452c05af65dd3a40ac61a484cc75a71357601bb9a5297aabe932b18780 SHA512 eb42c83edf30f49f2110c2cf04a08feb72c1cd5e6a3c0fb06ef28c8eb09feb8b97d143459ff0850a8b050d42090e2b1f3f851e43af72b21e6801a4ee80baaadb
-EBUILD xauth-9999.ebuild 587 BLAKE2B 1e8fe4a9f98c6bf3802132e5ca1a23eecf5c9761915a501f2517ba64f537e28ede6f3aae5d8a02c03df36d08a1e65f706637fe1a740f1657e02e62316a2e3988 SHA512 a1b3ebc2dda6f177bebbd7b818e9afd74711bccd984b36aa87c36549873ac93026da5c0e9a3a43ed85c428f7b0da14e80fe90ac7539164c084074efda1255393
+EBUILD xauth-1.1.3.ebuild 485 BLAKE2B 842d603728dd0a2a1d22c336e8dfe18fc9b69ea7fa9a3825630cfb8e7ad6e03047b950b805baef2b4f0c7b737d5d20aa79ff2779d27a2da37efd12c1eb64864b SHA512 938e1dfee21ac5436d44f55ece192a9c8ebf42143237628a5fe13687f5b3948858747dfa52f370ba434d9e549a4400395537ef1cc10f0587fbfaf5d8d961aae8
MISC metadata.xml 336 BLAKE2B e7efb568e90d3de70da870d88a12988c62c876085291bd426de3a6b3123e3f989eea78d4dc36e2e47cdd68b2f62c2f7c912c1f0e9ed8e92f4eecc017c63676ea SHA512 f210a30ab5f02fc443a1ba611bf07e72815d3089015ba5509dff6b62ee177cc50b6729157eff68633fe6163b7cd5d0d4a0b1a75f739984a50724639d043a2d58
diff --git a/x11-apps/xauth/xauth-1.1.3.ebuild b/x11-apps/xauth/xauth-1.1.3.ebuild
new file mode 100644
index 000000000000..d2dc7ea05342
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+DESCRIPTION="X authority file utility"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+)
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
deleted file mode 100644
index 316b60131355..000000000000
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-XORG_TARBALL_SUFFIX=xz
-inherit xorg-3
-
-if [[ ${PV} == 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="X authority file utility"
-
-RDEPEND="
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXext
- x11-libs/libXmu"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-src_configure() {
- local XORG_CONFIGURE_OPTIONS=(
- --enable-ipv6
- )
- xorg-3_src_configure
-}