summaryrefslogtreecommitdiff
path: root/x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch')
-rw-r--r--x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch26
1 files changed, 18 insertions, 8 deletions
diff --git a/x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch b/x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch
index 5b1104e71a13..dcf7fdcc17ac 100644
--- a/x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch
+++ b/x11-apps/mesa-progs/files/9.0.0-Disable-things-we-don-t-want.patch
@@ -1,20 +1,20 @@
-From 0e87b772b5d291ecf2cdc3f209321ea586918375 Mon Sep 17 00:00:00 2001
+From beccb3024fee949bfb7bdfd19225e93a7cb0e906 Mon Sep 17 00:00:00 2001
From: Matt Turner <mattst88@gmail.com>
Date: Thu, 18 Apr 2024 13:24:18 -0400
Subject: [PATCH] Disable things we don't want
---
- meson.build | 3 ++-
+ meson.build | 13 ++-----------
src/egl/opengl/meson.build | 28 ---------------------------
src/egl/opengles2/meson.build | 5 -----
src/meson.build | 2 --
src/util/gl_wrap.h | 2 --
src/util/meson.build | 9 +--------
src/xdemos/meson.build | 36 -----------------------------------
- 7 files changed, 3 insertions(+), 82 deletions(-)
+ 7 files changed, 3 insertions(+), 92 deletions(-)
diff --git a/meson.build b/meson.build
-index c1853f94..5424dc73 100644
+index c1853f94..d1457a35 100644
--- a/meson.build
+++ b/meson.build
@@ -52,7 +52,7 @@ dep_drm = dependency('libdrm',
@@ -26,10 +26,20 @@ index c1853f94..5424dc73 100644
required : get_option('x11'),
disabler : true
)
-@@ -97,6 +97,7 @@ if not dep_glu.found() and host_machine.system() != 'darwin'
- dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h',
- required : dep_x11.found())
- endif
+@@ -87,16 +87,7 @@ endif
+
+ dep_threads = dependency('threads')
+
+-dep_glu = dependency('glu', required : false)
+-# GLU is part of OpenGL.Framework
+-if not dep_glu.found() and host_machine.system() != 'darwin'
+- _glu_name = 'GLU'
+- if host_machine.system() == 'windows'
+- _glu_name = 'glu32'
+- endif
+- dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h',
+- required : dep_x11.found())
+-endif
+dep_glu = disabler()
dep_glx = dependency('glx', required: false, disabler : true)