summaryrefslogtreecommitdiff
path: root/www-servers/nginx/nginx-1.25.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/nginx/nginx-1.25.5.ebuild')
-rw-r--r--www-servers/nginx/nginx-1.25.5.ebuild25
1 files changed, 23 insertions, 2 deletions
diff --git a/www-servers/nginx/nginx-1.25.5.ebuild b/www-servers/nginx/nginx-1.25.5.ebuild
index f5bb4dfa7402..631386626414 100644
--- a/www-servers/nginx/nginx-1.25.5.ebuild
+++ b/www-servers/nginx/nginx-1.25.5.ebuild
@@ -153,6 +153,12 @@ HTTP_LDAP_MODULE_P="nginx-auth-ldap-${HTTP_LDAP_MODULE_PV}"
HTTP_LDAP_MODULE_URI="https://github.com/kvspb/nginx-auth-ldap/archive/${HTTP_LDAP_MODULE_PV}.tar.gz"
HTTP_LDAP_MODULE_WD="${WORKDIR}/nginx-auth-ldap-${HTTP_LDAP_MODULE_PV}"
+# nginx-vod-module (https://github.com/kaltura/nginx-vod-module, AGPL-3+)
+HTTP_VOD_MODULE_PV="1.33"
+HTTP_VOD_MODULE_P="nginx-vod-module-${HTTP_VOD_MODULE_PV}"
+HTTP_VOD_MODULE_URI="https://github.com/kaltura/nginx-vod-module/archive/${HTTP_VOD_MODULE_PV}.tar.gz"
+HTTP_VOD_MODULE_WD="${WORKDIR}/nginx-vod-module-${HTTP_VOD_MODULE_PV}"
+
# geoip2 (https://github.com/leev/ngx_http_geoip2_module, BSD-2)
GEOIP2_MODULE_PV="3.4"
GEOIP2_MODULE_P="ngx_http_geoip2_module-${GEOIP2_MODULE_PV}"
@@ -166,7 +172,7 @@ NJS_MODULE_URI="https://github.com/nginx/njs/archive/${NJS_MODULE_PV}.tar.gz"
NJS_MODULE_WD="${WORKDIR}/njs-${NJS_MODULE_PV}"
# nginx-tests (http://hg.nginx.org/nginx-tests, BSD-2)
-NGINX_TESTS_REV="24482e311749"
+NGINX_TESTS_REV="0b5ec15c62ed"
# We handle deps below ourselves
SSL_DEPS_SKIP=1
@@ -203,6 +209,7 @@ SRC_URI="https://nginx.org/download/${P}.tar.gz
nginx_modules_http_upload_progress? ( ${HTTP_UPLOAD_PROGRESS_MODULE_URI} -> ${HTTP_UPLOAD_PROGRESS_MODULE_P}.tar.gz )
nginx_modules_http_upstream_check? ( ${HTTP_UPSTREAM_CHECK_MODULE_URI} -> ${HTTP_UPSTREAM_CHECK_MODULE_P}.tar.gz )
nginx_modules_http_vhost_traffic_status? ( ${HTTP_VHOST_TRAFFIC_STATUS_MODULE_URI} -> ${HTTP_VHOST_TRAFFIC_STATUS_MODULE_P}.tar.gz )
+ nginx_modules_http_vod? ( ${HTTP_VOD_MODULE_URI} -> ${HTTP_VOD_MODULE_P}.tar.gz )
nginx_modules_stream_geoip2? ( ${GEOIP2_MODULE_URI} -> ${GEOIP2_MODULE_P}.tar.gz )
nginx_modules_stream_javascript? ( ${NJS_MODULE_URI} -> ${NJS_MODULE_P}.tar.gz )
rtmp? ( ${RTMP_MODULE_URI} -> ${RTMP_MODULE_P}.tar.gz )
@@ -252,6 +259,7 @@ NGINX_MODULES_3RD="
http_upload_progress
http_upstream_check
http_vhost_traffic_status
+ http_vod
stream_geoip2
stream_javascript
"
@@ -322,6 +330,7 @@ CDEPEND="
nginx_modules_http_dav_ext? ( dev-libs/libxml2 )
nginx_modules_http_security? ( dev-libs/modsecurity )
nginx_modules_http_auth_ldap? ( net-nds/openldap:=[ssl?] )
+ nginx_modules_http_vod? ( media-video/ffmpeg:0= )
nginx_modules_stream_geoip? ( dev-libs/geoip )
nginx_modules_stream_geoip2? ( dev-libs/libmaxminddb:= )"
RDEPEND="${CDEPEND}
@@ -365,7 +374,8 @@ REQUIRED_USE="pcre-jit? ( pcre )
nginx_modules_http_dav_ext? ( nginx_modules_http_dav nginx_modules_http_xslt )
nginx_modules_http_metrics? ( nginx_modules_http_stub_status )
nginx_modules_http_security? ( pcre )
- nginx_modules_http_push_stream? ( ssl )"
+ nginx_modules_http_push_stream? ( ssl )
+ nginx_modules_http_vod? ( threads )"
pkg_setup() {
NGINX_HOME="/var/lib/nginx"
@@ -620,6 +630,12 @@ src_configure() {
http_enabled=1
fi
+ if use nginx_modules_http_vod; then
+ http_enabled=1
+ export HTTP_POSTPONE=no
+ myconf+=( --add-module=${HTTP_VOD_MODULE_WD} )
+ fi
+
if [ $http_enabled ]; then
use http-cache || myconf+=( --without-http-cache )
use ssl && myconf+=( --with-http_ssl_module )
@@ -846,6 +862,11 @@ src_install() {
docinto ${HTTP_LDAP_MODULE_P}
dodoc "${HTTP_LDAP_MODULE_WD}"/example.conf
fi
+
+ if use nginx_modules_http_vod; then
+ docinto ${HTTP_VOD_MODULE_P}
+ dodoc "${HTTP_VOD_MODULE_WD}"/{CHANGELOG,README}.md
+ fi
}
src_test() {