summaryrefslogtreecommitdiff
path: root/www-servers/nginx-unit
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest4
-rw-r--r--www-servers/nginx-unit/metadata.xml6
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.5.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 1324e8d2aa2e..62b21b75485e 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,5 +1,7 @@
AUX nginx-unit.initd 291 BLAKE2B a4ce1b0269de3d991bfdf30b6183418d32e2c94d21ca0ab154b9f44521895227057cad1fd2ca72015a4c25c90250cc31a6aa2f637caaa564eee7769a48b4d355 SHA512 89db5f2116d11ff8e741b23e41692585ee7e2446fb6d214666af913a1fec9a2f6d300512cb8d3b6a83795e714d6f17403e22dc12fd9c76b0551c14b71b6fd998
DIST nginx-unit-1.3.tar.gz 401670 BLAKE2B 34a0ed9631c7061d1c71f8335103b0e266ef6f949afeb8cef283a7b5dd6c9f0a4835f20fdedd091af6950cd0897cb1ab48dea9f475e1b75a2872da7ac0090d10 SHA512 63a47b920bfdae7a7e034d616f520b27b46151a299cf5854373f7f8472043de0ffc98f9d62317c46e637857e0ef24668ded99be6e058315acf25b4e1c7f1ed09
+DIST nginx-unit-1.5.tar.gz 437636 BLAKE2B 9f7b89a800c933cc6d55a444c5a6c6326cf1694062026419af5e8a13e68b35c47b631d961611342e20c3d9338ca727ed7cc38c27b43443ec3f9abafd18f6684a SHA512 bde6bc7720cff03bf3967fde265c6763fc84f597a7c785eae0174726cb8ad7676f0adade892c2944abad831a667fff250a75aeacdca2d1bffb8c0f8fcd291ebd
EBUILD nginx-unit-1.3-r1.ebuild 1194 BLAKE2B dd27ff30e4113e9beb716ea2c73f6559fcde29bf1137b0361b73aa56a4c46a293928b6060eb61e2689d6bccb90a8452e7aa83621ea1768f326b7bd1a60202430 SHA512 af28c954708053a62ef0d2e534d05de59f5e05e8f1042488bcd25f6d0e4c0b4144e7b7ccc146c5b97a0d2f0ca1cc21542aff92082dfc38eeb0fbc9137802727c
EBUILD nginx-unit-1.3.ebuild 937 BLAKE2B 09d8c3e3e8e0d0737f94bb1b483479fdce591f3a60a8ac5dab65d94e361e04b6bc1099f6c78432af93469c21c995a0bbde85d916c143ccf92ed0124d3e835913 SHA512 498a05d21d8593c0d640fadabee04245dc7c2c49050c314a1366ae4edd52a268b6a5745aa9d7eecbd0383706cac6c02b7838e0c517206b55b6ddeed849cb9340
-MISC metadata.xml 787 BLAKE2B a88efd7d7a5fe988156edf4775a7d5aca875957d507ae2e95a014b6f1bbbea7c9d66e2081525c3a495bcc88e8541d8d7e3a09bf5426847065c488920c442ed3e SHA512 793dc1852eb308056c81240a596302d647ccf96aae0f2585dc0e68e2cd4dd9444dbb9e65454c640e78377d83a9261dcb343a0082f0cefcfb4f9b5d1259ade15f
+EBUILD nginx-unit-1.5.ebuild 1710 BLAKE2B b7f56ac87f182b82c07e43a0c3ebce21fd3295115afba5bcaa37f7e21d73194ece54fabf092cc1ee22ad809ffffd39b70c32ffcacf0f56a15b71003aad420715 SHA512 afe8679d7671538dc36ae7bf324bfb4e2f839f80cb2b588bebc4b8b4f6217e089538dddbe6dc4dcf22a90f707a965908d3fddbc68d077829d409010745250bd5
+MISC metadata.xml 998 BLAKE2B 8ff6ba591f5496f7bcaa133f4429c5f87d2a09fbb7fb01dee03795997ae6740645b2348d3589a5ecc12ca4a37310df3866231782ac745ce76b0fff689690e88b SHA512 74afba5a56ca0f5966a1cdf6a4a8de1fe690b3aa01d4b55c84ce5cdc065eeb16a0d24e9a930a8c2d0eba43b1cbee27a2267c9e0cd8f4fd2048999c69eae80fa2
diff --git a/www-servers/nginx-unit/metadata.xml b/www-servers/nginx-unit/metadata.xml
index 7660440b3f51..73c93269432b 100644
--- a/www-servers/nginx-unit/metadata.xml
+++ b/www-servers/nginx-unit/metadata.xml
@@ -16,6 +16,12 @@
reconfiguration of specific application parameters as needed by the
engineering or operations.
</longdescription>
+ <use>
+ <flag name="php5-6">Support for PHP 5.6</flag>
+ <flag name="php7-0">Support for PHP 7.0</flag>
+ <flag name="php7-1">Support for PHP 7.1</flag>
+ <flag name="php7-2">Support for PHP 7.2</flag>
+ </use>
<upstream>
<remote-id type="github">nginx/unit</remote-id>
</upstream>
diff --git a/www-servers/nginx-unit/nginx-unit-1.5.ebuild b/www-servers/nginx-unit/nginx-unit-1.5.ebuild
new file mode 100644
index 000000000000..e1eb3635fb1c
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{3,4,5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php5-6? ( dev-lang/php:5.6[embed] )
+ php7-0? ( dev-lang/php:7.0[embed] )
+ php7-1? ( dev-lang/php:7.1[embed] )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ ./configure \
+ --control=unix:/run/${PN}.sock \
+ --ld-opt="${LDFLAGS}" \
+ --log=/var/log/${PN} \
+ --modules=$(get_libdir)/${PN} \
+ --pid=/run/${PN}.pid \
+ --prefix=/usr \
+ --state=/var/lib/${PN} || die "Core configuration failed"
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}