summaryrefslogtreecommitdiff
path: root/www-servers/h2o/h2o-2.2.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/h2o/h2o-2.2.6-r1.ebuild')
-rw-r--r--www-servers/h2o/h2o-2.2.6-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/www-servers/h2o/h2o-2.2.6-r1.ebuild b/www-servers/h2o/h2o-2.2.6-r1.ebuild
index 33ece8ab07b7..01434dbf32a5 100644
--- a/www-servers/h2o/h2o-2.2.6-r1.ebuild
+++ b/www-servers/h2o/h2o-2.2.6-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
CMAKE_MAKEFILE_GENERATOR="emake"
SSL_DEPS_SKIP=1
-USE_RUBY="ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31"
inherit cmake ruby-single ssl-cert systemd toolchain-funcs
@@ -38,7 +38,10 @@ BDEPEND="libh2o? ( virtual/pkgconfig )
virtual/pkgconfig
)"
-PATCHES=( "${FILESDIR}"/${PN}-2.2-mruby.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-mruby.patch
+ "${FILESDIR}"/${PN}-2.2-ruby30.patch
+)
src_prepare() {
cmake_src_prepare