summaryrefslogtreecommitdiff
path: root/www-plugins/lightspark
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/Manifest2
-rw-r--r--www-plugins/lightspark/lightspark-0.8.7.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
index 9bb87936aaf1..c7dce38865c7 100644
--- a/www-plugins/lightspark/Manifest
+++ b/www-plugins/lightspark/Manifest
@@ -1,3 +1,5 @@
DIST lightspark-0.8.6.1.tar.gz 5419194 BLAKE2B dfe56f604c6dd9f9848c1cedffce5bc2a20f51a8b42405f5a38ddbc5c5a1db87e69cba99f5045cd7f60957e46992da8442d95d7ef929bcb806ed5ab0a17f084e SHA512 ea54b3d66acfcb12aac271669d550f6aa1709db59d4bcc005479b7be394a4ca30473a993a780c632228eeaad2977d97cdbcadff5cf8abbbf07503f9d56192f31
+DIST lightspark-0.8.7.tar.gz 5440706 BLAKE2B 53486183672c35a8b8040177ebc738e588c3ea39a316d2dd10fc4868393b0befea5ac9f411cdb87aad608f02df2f04e07b4a7f8a0635c0f6e0dee465469709f4 SHA512 a0207629238054d669710fcb4d6b1904624d4ed8fb19cf822447e55107d6c3596f6e9fb425c14968365a1c8224b7c3a899008428fd69c9714a03a74230e64f2f
EBUILD lightspark-0.8.6.1.ebuild 2498 BLAKE2B 7b1850205941a6424fa80fe22c7ceb80e44acbd4d840de2f7e0efa3067efd81c80f5c85a5fc684cb40cf6bae1020d167c696252141b72a1a536533ff60d5abe0 SHA512 c483d090fef31956943a4d632ad311c25f021ffbcbe8a6c576e7586546da40ac396555e6875e622a47e5c62d9d4238cff37df6790e47acaff55519b5690b3b7d
+EBUILD lightspark-0.8.7.ebuild 2475 BLAKE2B 83db3fb1b1a7537c5e2e1295371a0449a1fa1dd17bc51ee8b7dae5404194029f9402de10c94c4346aff8cfd3892af96b5f73d9c8ce86743e99f362487531b8d9 SHA512 3d29ff490c65571f55e5cb2b93e3d81585099c9dcb8dd9ad29116735d1d458cb20034fafcfdcb02adb40ccd8553fd4049512e31fa28708b66236c847530c6fba
MISC metadata.xml 729 BLAKE2B c6709bbbb2b685aec70f81c095b30f1c7acb65847c409d67131a733fcdafbd908b72c17b8acd60ee93707ac1bc4f38c0267778bdf346d910e4ba9cd521cd6714 SHA512 a1db1257f8102dc502ee0d275982ae94c5ed11419689066ee9f403df642831a1e2dd3d386d120c21ba74e59050e34f44b69e4dc381cc29136b3b3d7197589b64
diff --git a/www-plugins/lightspark/lightspark-0.8.7.ebuild b/www-plugins/lightspark/lightspark-0.8.7.ebuild
new file mode 100644
index 000000000000..29b4fcc7e999
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.8.7.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="https://lightspark.github.io/"
+SRC_URI="
+ https://github.com/lightspark/lightspark/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${P/_rc*/}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2 curl ffmpeg gles2-only nsplugin ppapi profile rtmp"
+
+# Note: no LLVM since it's broken upstream
+RDEPEND="
+ app-arch/xz-utils:=
+ dev-libs/glib
+ dev-libs/libpcre:=[cxx]
+ media-fonts/liberation-fonts
+ media-libs/freetype:=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/libsdl2
+ sys-libs/zlib:=
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/pango
+ curl? ( net-misc/curl:= )
+ ffmpeg? ( media-video/ffmpeg:= )
+ gles2-only? ( media-libs/mesa:=[gles2] )
+ !gles2-only? (
+ >=media-libs/glew-1.5.3:=
+ virtual/opengl:0=
+ )
+ rtmp? ( media-video/rtmpdump:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CURL=$(usex curl)
+ -DENABLE_GLES2=$(usex gles2-only)
+ -DENABLE_LIBAVCODEC=$(usex ffmpeg)
+ -DENABLE_RTMP=$(usex rtmp)
+
+ -DENABLE_MEMORY_USAGE_PROFILING=$(usex profile)
+ -DENABLE_PROFILING=$(usex profile)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+
+ -DCOMPILE_NPAPI_PLUGIN=$(usex nsplugin)
+ -DPLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins
+ # TODO: install /etc/chromium file? block adobe-flash?
+ -DCOMPILE_PPAPI_PLUGIN=$(usex ppapi)
+ -DPPAPI_PLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/chromium-browser/${PN}
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use nsplugin; then
+ # copied from nsplugins.eclass, that's broken in EAPI 7
+ dodir /usr/$(get_libdir)/nsbrowser/plugins
+ dosym ../../lightspark/plugins/liblightsparkplugin.so \
+ /usr/$(get_libdir)/nsbrowser/plugins/liblightsparkplugin.so
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ if use nsplugin && has_version "www-plugins/gnash[nsplugin]"; then
+ elog "Having two plugins installed for the same MIME type may confuse"
+ elog "Mozilla based browsers. It is recommended to disable the nsplugin"
+ elog "USE flag for either gnash or lightspark. For details, see"
+ elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}