summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-9999.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild63
1 files changed, 35 insertions, 28 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 3d0c12b40655..7cb5d6ee3504 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~arm64 ~x86"
fi
-DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+DESCRIPTION="Keyboard-driven, vim-like browser based on Python and Qt"
HOMEPAGE="https://www.qutebrowser.org/"
LICENSE="GPL-3+"
@@ -24,23 +24,25 @@ SLOT="0"
IUSE="+adblock pdf widevine"
RDEPEND="
- dev-qt/qtcore:5[icu]
- dev-qt/qtgui:5[png]
$(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,gui,network,opengl,printsupport,sql,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP},libyaml(+)]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/zipp[${PYTHON_USEDEP}]
- adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
+ adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )
+ ')
+ dev-qt/qtcore:5[icu]
+ dev-qt/qtgui:5[png]
pdf? ( <www-plugins/pdfjs-3 )
widevine? ( www-plugins/chrome-binary-plugins )"
BDEPEND="
$(python_gen_cond_dep '
test? (
+ dev-python/PyQt5[testlib]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/cheroot[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
@@ -51,8 +53,9 @@ BDEPEND="
dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
dev-python/pytest-xvfb[${PYTHON_USEDEP}]
dev-python/tldextract[${PYTHON_USEDEP}]
- )')"
-[[ ${PV} != 9999 ]] || BDEPEND+=" app-text/asciidoc"
+ )
+ ')"
+[[ ${PV} == 9999 ]] && BDEPEND+=" app-text/asciidoc"
distutils_enable_tests pytest
@@ -60,13 +63,14 @@ src_prepare() {
distutils-r1_src_prepare
if use pdf; then
- sed '/^content.pdfjs:/,+1s/false/true/' \
+ sed -e '/^content.pdfjs:/,+1s/false/true/' \
-i ${PN}/config/configdata.yml || die
fi
- if use widevine; then
+ if use widevine && use prefix; then
+ # hack: QtWebEngine knows Gentoo's widevine, but not with ${EPREFIX}
local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
- sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
+ sed -e "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
-i ${PN}/config/qtargs.py || die
fi
@@ -75,18 +79,21 @@ src_prepare() {
if [[ ${PV} == 9999 ]]; then
# call asciidoc(1) rather than the single target python module
- sed '/cmdline = /s/= .*/= ["asciidoc"]/' \
+ sed -e '/cmdline = /s/= .*/= ["asciidoc"]/' \
-i scripts/asciidoc2html.py || die
"${EPYTHON}" scripts/asciidoc2html.py || die
fi
- # these plugins/tests are unnecessary here and have extra dependencies
- sed -e '/pytest-benchmark/d;s/--benchmark[^ ]*//' \
- -e '/pytest-instafail/d;s/--instafail//' \
+ # disable unnecessary tests/plugins that need extras
+ sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
+ -e '/pytest-instafail/d' -e 's/--instafail//' \
-i pytest.ini || die
- [[ ${PV} == 9999 ]] || rm tests/unit/scripts/test_problemmatchers.py || die
- [[ ${PV} != 9999 ]] || rm tests/unit/scripts/test_run_vulture.py || die
+ if [[ ${PV} == 9999 ]]; then
+ rm tests/unit/scripts/test_run_vulture.py || die
+ else
+ rm tests/unit/scripts/test_problemmatchers.py || die
+ fi
}
python_test() {
@@ -94,21 +101,21 @@ python_test() {
local EPYTEST_DESELECT=(
# end2end and other IPC tests are broken with "Name error" if
- # socket path is over 104 characters (=124 in /var/tmp/portage)
+ # socket path is over ~104 characters (=124 in /var/tmp/portage)
# https://github.com/qutebrowser/qutebrowser/issues/888 (not just OSX)
tests/end2end
tests/unit/misc/test_ipc.py
- # tests that don't know about our newer qtwebengine
- tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
- tests/unit/utils/test_version.py::TestChromiumVersion
- # may misbehave depending on installed old python versions
+ # calls eclass' python2 "failure" wrapper
tests/unit/misc/test_checkpyver.py::test_old_python
- # bug 819393
- tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
# not worth running dbus over
tests/unit/browser/test_notification.py::TestDBus
+ # bug 819393
+ tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
+ # tests that don't know about our newer qtwebengine:5
+ tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
)
- use widevine && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )
+ # qtargs are mangled with widevine+prefix
+ use widevine && use prefix && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )
# skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
epytest -p xvfb -k 'not _bench and not _matches_tree and not _warning'