summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-9999.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild55
1 files changed, 36 insertions, 19 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index a1932f04f051..255fa35da86c 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,23 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS="rdepend"
-inherit desktop distutils-r1 optfeature xdg-utils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+inherit desktop distutils-r1 git-r3 optfeature xdg-utils
DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -29,9 +22,10 @@ RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/cssutils[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_{7,8})
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.6.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pypeg2[${PYTHON_USEDEP}]
dev-python/PyQt5[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
@@ -44,6 +38,11 @@ distutils_enable_tests setup.py
# isn't complete and X11 is required in order to start up qutebrowser.
RESTRICT="test"
+python_compile() {
+ ${EPYTHON} scripts/asciidoc2html.py || die
+ distutils-r1_python_compile
+}
+
python_compile_all() {
a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
}
@@ -54,14 +53,32 @@ python_install_all() {
doicon -s scalable icons/${PN}.svg
if use scripts; then
- # Install only those userscripts that have an explicit license header
+ insinto /usr/share/qutebrowser/userscripts/
+ doins misc/userscripts/README.md
exeinto /usr/share/qutebrowser/userscripts/
- doexe misc/userscripts/dmenu_qutebrowser
- doexe misc/userscripts/openfeeds
- doexe misc/userscripts/qute-keepass
- doexe misc/userscripts/qute-pass
- doexe misc/userscripts/rss
- doexe misc/userscripts/tor_identity
+ doexe misc/userscripts/add-nextcloud-bookmarks \
+ misc/userscripts/add-nextcloud-cookbook \
+ misc/userscripts/cast \
+ misc/userscripts/dmenu_qutebrowser \
+ misc/userscripts/format_json \
+ misc/userscripts/getbib \
+ misc/userscripts/kodi \
+ misc/userscripts/open_download \
+ misc/userscripts/openfeeds \
+ misc/userscripts/password_fill \
+ misc/userscripts/qr \
+ misc/userscripts/qute-bitwarden \
+ misc/userscripts/qutedmenu \
+ misc/userscripts/qute-keepass \
+ misc/userscripts/qute-lastpass \
+ misc/userscripts/qute-pass \
+ misc/userscripts/readability \
+ misc/userscripts/readability-js \
+ misc/userscripts/ripbang \
+ misc/userscripts/rss \
+ misc/userscripts/taskadd \
+ misc/userscripts/tor_identity \
+ misc/userscripts/view_in_mpv
fi
distutils-r1_python_install_all