summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-3.1.0.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-3.1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/www-client/qutebrowser/qutebrowser-3.1.0.ebuild b/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
index 7ddeb9db71fb..6134e6cba9f4 100644
--- a/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -152,8 +152,16 @@ python_test() {
tests/unit/mainwindow/test_tabwidget.py::TestTabWidget::test_tab_text_not_edlided_for_wide_tabs
)
- # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
- epytest -p xvfb -k 'not _bench and not _matches_tree and not _warning'
+ local epytestargs=(
+ # prefer pytest-xvfb over virtx given same upstream and is expected
+ -p xvfb
+ # skip warning tests broken by -wdefault, and benchmarks
+ -k 'not _bench and not _matches_tree and not _warning'
+ # override eclass' settings, tempdirs are re-used by Qt
+ -o tmp_path_retention_policy=all
+ )
+
+ epytest "${epytestargs[@]}"
}
python_install_all() {