summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-2.4.0.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-2.4.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.4.0.ebuild b/www-client/qutebrowser/qutebrowser-2.4.0.ebuild
index 82cb9d908b85..d18f294eab0a 100644
--- a/www-client/qutebrowser/qutebrowser-2.4.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.4.0.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
else
SRC_URI="https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="amd64 ~arm64 ~x86"
fi
DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
@@ -33,7 +33,7 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP},libyaml(+)]
>=dev-python/typing-extensions-3.10.0.2[${PYTHON_USEDEP}]
>=dev-python/zipp-3.6.0[${PYTHON_USEDEP}]
adblock? ( >=dev-python/adblock-0.5.0[${PYTHON_USEDEP}] )
@@ -119,6 +119,6 @@ pkg_postinst() {
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
elog "have additional dependencies not covered by this ebuild, for example"
- elog "view_in_mpv needs media-video/mpv setup to use yt-dlp or youtube-dl."
+ elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
fi
}