summaryrefslogtreecommitdiff
path: root/www-client/pybugz/pybugz-0.13-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/pybugz/pybugz-0.13-r3.ebuild')
-rw-r--r--www-client/pybugz/pybugz-0.13-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-client/pybugz/pybugz-0.13-r3.ebuild b/www-client/pybugz/pybugz-0.13-r3.ebuild
new file mode 100644
index 000000000000..17680b4e1e24
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.13-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="readline(+),ssl(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+}