summaryrefslogtreecommitdiff
path: root/www-client/otter/otter-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/otter/otter-9999.ebuild')
-rw-r--r--www-client/otter/otter-9999.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/www-client/otter/otter-9999.ebuild b/www-client/otter/otter-9999.ebuild
index dd20d3231ae6..7b5172796e7e 100644
--- a/www-client/otter/otter-9999.ebuild
+++ b/www-client/otter/otter-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils desktop git-r3 xdg-utils
+inherit cmake desktop git-r3 xdg-utils
DESCRIPTION="Project aiming to recreate classic Opera (12.x) UI using Qt5"
HOMEPAGE="https://otter-browser.org/"
-EGIT_REPO_URI="https://github.com/OtterBrowser/otter-browser"
+EGIT_REPO_URI="https://github.com/OtterBrowser/${PN}-browser"
LICENSE="GPL-3"
SLOT="0"
@@ -25,18 +25,21 @@ DEPEND="
dev-qt/qtscript:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
- dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtxmlpatterns:5
spell? ( kde-frameworks/sonnet )
+ >=dev-qt/qtwebengine-5.9:5[widgets]
"
RDEPEND="
${DEPEND}
"
DOCS=( CHANGELOG CONTRIBUTING.md TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.01-webengine.patch
+)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if [[ -n ${LINGUAS} ]]; then
local lingua
@@ -55,8 +58,17 @@ src_prepare() {
fi
}
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_QTWEBENGINE=true
+ -DENABLE_QTWEBKIT=false
+ )
+
+ cmake_src_configure
+}
+
src_install() {
- cmake-utils_src_install
+ cmake_src_install
domenu ${PN}-browser.desktop
}