summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-93.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-93.0.ebuild')
-rw-r--r--www-client/firefox/firefox-93.0.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-93.0.ebuild b/www-client/firefox/firefox-93.0.ebuild
index 00f330717b92..0a7fa6f83161 100644
--- a/www-client/firefox/firefox-93.0.ebuild
+++ b/www-client/firefox/firefox-93.0.ebuild
@@ -3,9 +3,9 @@
EAPI="7"
-FIREFOX_PATCHSET="firefox-93-patches-01.tar.xz"
+FIREFOX_PATCHSET="firefox-93-patches-02.tar.xz"
-LLVM_MAX_SLOT=12
+LLVM_MAX_SLOT=13
PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="ncurses,sqlite,ssl"
@@ -78,6 +78,14 @@ BDEPEND="${PYTHON_DEPS}
>=virtual/rust-1.51.0
|| (
(
+ sys-devel/clang:13
+ sys-devel/llvm:13
+ clang? (
+ =sys-devel/lld-13*
+ pgo? ( =sys-libs/compiler-rt-sanitizers-13*[profile] )
+ )
+ )
+ (
sys-devel/clang:12
sys-devel/llvm:12
clang? (
@@ -597,6 +605,9 @@ src_configure() {
# python/mach/mach/mixin/process.py fails to detect SHELL
export SHELL="${EPREFIX}/bin/bash"
+ # Set state path
+ export MOZBUILD_STATE_PATH="${BUILD_DIR}"
+
# Set MOZCONFIG
export MOZCONFIG="${S}/.mozconfig"