summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-75.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-75.0.ebuild')
-rw-r--r--www-client/firefox/firefox-75.0.ebuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-75.0.ebuild b/www-client/firefox/firefox-75.0.ebuild
index 6661604f0cc3..9327b6461110 100644
--- a/www-client/firefox/firefox-75.0.ebuild
+++ b/www-client/firefox/firefox-75.0.ebuild
@@ -27,7 +27,7 @@ if [[ ${MOZ_ESR} == 1 ]] ; then
fi
# Patch version
-PATCH="${PN}-75.0-patches-2"
+PATCH="${PN}-75.0-patches-5"
MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZ_SRC_URI="${MOZ_HTTP_URI}/${MOZ_PV}/source/firefox-${MOZ_PV}.source.tar.xz"
@@ -41,8 +41,9 @@ fi
LLVM_MAX_SLOT=10
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
- gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
- autotools mozlinguas-v2 virtualx eapi7-ver
+ gnome2-utils llvm mozcoreconf-v6 multiprocessing \
+ pax-utils xdg-utils autotools mozlinguas-v2 virtualx \
+ eapi7-ver
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -130,7 +131,7 @@ DEPEND="${CDEPEND}
app-arch/zip
app-arch/unzip
>=dev-util/cbindgen-0.13.0
- >=net-libs/nodejs-8.11.0
+ >=net-libs/nodejs-10.19.0
>=sys-devel/binutils-2.30
sys-apps/findutils
|| (
@@ -297,6 +298,10 @@ pkg_setup() {
# Workaround for #627726
if has ccache ${FEATURES} ; then
+ if use clang && use pgo ; then
+ die "Using FEATURES=ccache with USE=clang and USE=pgo is currently known to be broken (bug #718632)."
+ fi
+
einfo "Fixing PATH for FEATURES=ccache ..."
PATH=$(fix_path 'ccache/bin')
elif has distcc ${FEATURES} ; then
@@ -315,9 +320,18 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/firefox"
+ # Make LTO respect MAKEOPTS
+ sed -i \
+ -e "s/multiprocessing.cpu_count()/$(makeopts_jobs)/" \
+ "${S}"/build/moz.configure/lto-pgo.configure \
+ || die "sed failed to set num_cores"
+
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ einfo "Removing pre-built binaries ..."
+ find "${S}"/third_party -type f \( -name '*.so' -o -name '*.o' \) -print -delete || die
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \