summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-60.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-60.2.0.ebuild')
-rw-r--r--www-client/firefox/firefox-60.2.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-60.2.0.ebuild b/www-client/firefox/firefox-60.2.0.ebuild
index ea3ee61d1e1f..b32f7700abe8 100644
--- a/www-client/firefox/firefox-60.2.0.ebuild
+++ b/www-client/firefox/firefox-60.2.0.ebuild
@@ -35,7 +35,7 @@ inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/firefox"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
@@ -125,7 +125,8 @@ src_prepare() {
rm "${WORKDIR}/firefox/2005_ffmpeg4.patch"
eapply "${WORKDIR}/firefox"
- eapply "${FILESDIR}/bug_1461221.patch"
+ eapply "${FILESDIR}"/bug_1461221.patch
+ eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
# Enable gnomebreakpad
if use debug ; then
@@ -215,6 +216,13 @@ src_configure() {
# Only available on mozilla-overlay for experimentation -- Removed in Gentoo repo per bug 571180
#use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
+ # Disable built-in ccache support to avoid sandbox violation, #665420
+ # Use FEATURES=ccache instead!
+ mozconfig_annotate '' --without-ccache
+ sed -i -e 's/ccache_stats = None/return None/' \
+ python/mozbuild/mozbuild/controller/building.py || \
+ die "Failed to disable ccache stats call"
+
# Setup api key for location services
echo -n "${_google_api_key}" > "${S}"/google-api-key
mozconfig_annotate '' --with-google-api-keyfile="${S}/google-api-key"