summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-125.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-125.0.2.ebuild')
-rw-r--r--www-client/firefox/firefox-125.0.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-125.0.2.ebuild b/www-client/firefox/firefox-125.0.2.ebuild
index 86caf122eb6f..7c34e086a5d2 100644
--- a/www-client/firefox/firefox-125.0.2.ebuild
+++ b/www-client/firefox/firefox-125.0.2.ebuild
@@ -635,6 +635,8 @@ src_prepare() {
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
export RUST_TARGET="i686-unknown-linux-musl"
+ elif use arm64 ; then
+ export RUST_TARGET="aarch64-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi
@@ -1046,7 +1048,7 @@ src_configure() {
fi
# elf-hack
- # Filter "-z,pack-relative-relocs" and let the build system handle it instead.
+ # Filter "-z,pack-relative-relocs" and let the build system handle it instead.
if use amd64 || use x86 ; then
filter-flags "-z,pack-relative-relocs"