summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-121.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-121.0.ebuild')
-rw-r--r--www-client/firefox/firefox-121.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-121.0.ebuild b/www-client/firefox/firefox-121.0.ebuild
index af2883ae3dd3..2c539e6c1a5e 100644
--- a/www-client/firefox/firefox-121.0.ebuild
+++ b/www-client/firefox/firefox-121.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -673,7 +673,7 @@ src_prepare() {
rm -v "${WORKDIR}"/firefox-patches/0028-bmo-1862601-system-icu-74.patch || die
# Workaround for bgo#915651 on musl
- if ! use elibc_glibc ; then
+ if use elibc_glibc ; then
rm -v "${WORKDIR}"/firefox-patches/*bgo-748849-RUST_TARGET_override.patch || die
fi
@@ -690,7 +690,7 @@ src_prepare() {
if use amd64 ; then
export RUST_TARGET="x86_64-unknown-linux-musl"
elif use x86 ; then
- export RUST_TARGET="x86-unknown-linux-musl"
+ export RUST_TARGET="i686-unknown-linux-musl"
else
die "Unknown musl chost, please post your rustc -vV along with emerge --info on Gentoo's bug #915651"
fi