summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-115.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-115.9.1.ebuild')
-rw-r--r--www-client/firefox/firefox-115.9.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-115.9.1.ebuild b/www-client/firefox/firefox-115.9.1.ebuild
index 2216b95968a4..c433643b1f37 100644
--- a/www-client/firefox/firefox-115.9.1.ebuild
+++ b/www-client/firefox/firefox-115.9.1.ebuild
@@ -1061,7 +1061,13 @@ src_configure() {
# With Firefox-115esr elf-hack=relr isn't available (only in rapid).
# Solution: Disable build system's elf-hack completely, and add "-z,pack-relative-relocs"
# manually with gcc.
- mozconfig_add_options_ac 'elf-hack disabled' --disable-elf-hack
+ #
+ # elf-hack configure option isn't available on ppc64, #916259, #929244.
+ if use ppc64; then
+ :;
+ else
+ mozconfig_add_options_ac 'elf-hack disabled' --disable-elf-hack
+ fi
if use amd64 || use x86 ; then
! use clang && append-ldflags "-z,pack-relative-relocs"