summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-107.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-107.0.ebuild')
-rw-r--r--www-client/firefox/firefox-107.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/www-client/firefox/firefox-107.0.ebuild b/www-client/firefox/firefox-107.0.ebuild
index 9e3ee21d03b8..71eb99bd7b77 100644
--- a/www-client/firefox/firefox-107.0.ebuild
+++ b/www-client/firefox/firefox-107.0.ebuild
@@ -89,6 +89,7 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:15
clang? (
sys-devel/lld:15
+ virtual/rust:0/llvm-15
pgo? ( =sys-libs/compiler-rt-sanitizers-15*[profile] )
)
)
@@ -97,19 +98,17 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:14
clang? (
sys-devel/lld:14
+ virtual/rust:0/llvm-14
pgo? ( =sys-libs/compiler-rt-sanitizers-14*[profile] )
)
)
)
- || (
- virtual/rust:0/llvm-15
- virtual/rust:0/llvm-14
- )
app-arch/unzip
app-arch/zip
>=dev-util/cbindgen-0.24.3
net-libs/nodejs
virtual/pkgconfig
+ !clang? ( virtual/rust )
amd64? ( >=dev-lang/nasm-2.14 )
x86? ( >=dev-lang/nasm-2.14 )
pgo? (
@@ -234,9 +233,14 @@ llvm_check_deps() {
return 1
fi
+ if ! has_version -b "virtual/rust:0/llvm-${LLVM_SLOT}" ; then
+ einfo "virtual/rust:0/llvm-${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if use pgo ; then
- if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
- einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
+ einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi