summaryrefslogtreecommitdiff
path: root/www-client/dillo
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/Manifest4
-rw-r--r--www-client/dillo/dillo-3.1.1.ebuild103
-rw-r--r--www-client/dillo/dillo-9999.ebuild103
-rw-r--r--www-client/dillo/metadata.xml16
4 files changed, 226 insertions, 0 deletions
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
new file mode 100644
index 000000000000..471197215312
--- /dev/null
+++ b/www-client/dillo/Manifest
@@ -0,0 +1,4 @@
+DIST dillo-3.1.1.tar.bz2 1026711 BLAKE2B 81fbaf527f89160bfddf4bc51048dab8f1487b735e6d9cb9679deb46cda666158bb6b0d469ec28691167cd9d9657a12f5d5f5ed5b6c1cb0102963d611b4e2ece SHA512 2f6ad315c246638e91af13fbeb8a846b756c222aaf2275efb1bff6bae08130bb4b8fda9c09cd33925911c424fe536cf7a587e6657de9a13d63733714c86533c1
+EBUILD dillo-3.1.1.ebuild 1763 BLAKE2B cec4b48433c4d771a14ceee1594ef92adabee63968b151a67871ac359e2d603329a21c340a782d0667beabc17f2fbce0ec1631f3fc1539661ab16a1f08b9d490 SHA512 ec8b4305f233c7bec4ec87be1dc07a827d5e42a08b478e453cf57291f53bce49561fd4f1ea6d6ac25af9da905689d21cfb96b33e74b09bc0ca14f2ad2dc782cf
+EBUILD dillo-9999.ebuild 1763 BLAKE2B cec4b48433c4d771a14ceee1594ef92adabee63968b151a67871ac359e2d603329a21c340a782d0667beabc17f2fbce0ec1631f3fc1539661ab16a1f08b9d490 SHA512 ec8b4305f233c7bec4ec87be1dc07a827d5e42a08b478e453cf57291f53bce49561fd4f1ea6d6ac25af9da905689d21cfb96b33e74b09bc0ca14f2ad2dc782cf
+MISC metadata.xml 645 BLAKE2B 1c0dc7392fa848bf1f229641929105e23f3be0253035c4da8d1b8ac499ed60a90ca7578ffc2a4fdcd8808f25fab8e93678081b621d0cb68f0629e19554958a2d SHA512 10acbeacf15254145d7cc2dbedc75d064f045b0c7d76e5facbf364e15c9e0af1fcf3ab12803323dd827c7540de71770926ddbd123a851da16dad2cd5e1f89248
diff --git a/www-client/dillo/dillo-3.1.1.ebuild b/www-client/dillo/dillo-3.1.1.ebuild
new file mode 100644
index 000000000000..b40a1c5d1e76
--- /dev/null
+++ b/www-client/dillo/dillo-3.1.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs virtualx xdg-utils
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://dillo-browser.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dillo-browser/dillo.git"
+else
+ SRC_URI="https://github.com/dillo-browser/dillo/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc +gif +jpeg mbedtls +png +ssl +openssl +xembed"
+REQUIRED_USE="
+ ssl? ( || ( openssl mbedtls ) )
+"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3:1
+ sys-libs/zlib
+ x11-libs/libX11
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.2:= )
+ ssl? (
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+ test? (
+ media-gfx/imagemagick
+ x11-apps/xwd
+ x11-apps/xwininfo
+ )
+
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ app-text/texlive
+ )
+"
+
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug rtfl)
+ $(use_enable gif)
+ $(use_enable jpeg)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable png)
+ $(use_enable ssl tls)
+ $(use_enable xembed)
+ --enable-ipv6
+ )
+
+ use test && myeconfargs+=( --enable-html-tests=yes )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # The test suite consistently fails with -jN in portage
+ virtx emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
new file mode 100644
index 000000000000..b40a1c5d1e76
--- /dev/null
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs virtualx xdg-utils
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://dillo-browser.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dillo-browser/dillo.git"
+else
+ SRC_URI="https://github.com/dillo-browser/dillo/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc +gif +jpeg mbedtls +png +ssl +openssl +xembed"
+REQUIRED_USE="
+ ssl? ( || ( openssl mbedtls ) )
+"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3:1
+ sys-libs/zlib
+ x11-libs/libX11
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.2:= )
+ ssl? (
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+ test? (
+ media-gfx/imagemagick
+ x11-apps/xwd
+ x11-apps/xwininfo
+ )
+
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ app-text/texlive
+ )
+"
+
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug rtfl)
+ $(use_enable gif)
+ $(use_enable jpeg)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable png)
+ $(use_enable ssl tls)
+ $(use_enable xembed)
+ --enable-ipv6
+ )
+
+ use test && myeconfargs+=( --enable-html-tests=yes )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # The test suite consistently fails with -jN in portage
+ virtx emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/www-client/dillo/metadata.xml b/www-client/dillo/metadata.xml
new file mode 100644
index 000000000000..3e919778f73f
--- /dev/null
+++ b/www-client/dillo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>Kangie@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <use>
+ <flag name="openssl">Build against the <pkg>dev-libs/openssl</pkg> library for TLS support.</flag>
+ <flag name="mbedtls">Build against the <pkg>net-libs/mbedtls</pkg> library for TLS support.</flag>
+ <flag name="xembed">Enable XEmbed protocol support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">dillo-browser/dillo</remote-id>
+ </upstream>
+</pkgmetadata>