summaryrefslogtreecommitdiff
path: root/www-client/chromium/chromium-125.0.6422.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-125.0.6422.4.ebuild')
-rw-r--r--www-client/chromium/chromium-125.0.6422.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-125.0.6422.4.ebuild b/www-client/chromium/chromium-125.0.6422.4.ebuild
index c689e3abafef..8f0934a3f723 100644
--- a/www-client/chromium/chromium-125.0.6422.4.ebuild
+++ b/www-client/chromium/chromium-125.0.6422.4.ebuild
@@ -64,7 +64,7 @@ CHROMIUM_LANGS="af am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu
sv sw ta te th tr uk ur vi zh-CN zh-TW"
inherit check-reqs chromium-2 desktop flag-o-matic llvm ninja-utils pax-utils
-inherit python-any-r1 qmake-utils readme.gentoo-r1 toolchain-funcs virtualx xdg-utils
+inherit python-any-r1 qmake-utils readme.gentoo-r1 systemd toolchain-funcs virtualx xdg-utils
DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://www.chromium.org/"
@@ -1436,4 +1436,12 @@ pkg_postinst() {
elog "/etc/chromium/default."
fi
fi
+
+ if systemd_is_booted && ! -f /etc/machine-id ; then
+ ewarn "The lack of an '/etc/machine-id' file on this system booted with systemd"
+ ewarn "indicates that the Gentoo handbook was not followed to completion."
+ ewarn ""
+ ewarn "Chromium is known to behave unpredictably with this system configuration;"
+ ewarn "please complete the configuration of this system before logging any bugs."
+ fi
}