summaryrefslogtreecommitdiff
path: root/www-apps/trickster/trickster-1.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/trickster/trickster-1.1.5.ebuild')
-rw-r--r--www-apps/trickster/trickster-1.1.5.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/www-apps/trickster/trickster-1.1.5.ebuild b/www-apps/trickster/trickster-1.1.5.ebuild
index 8f4e9be4ae1f..eb10489e59cb 100644
--- a/www-apps/trickster/trickster-1.1.5.ebuild
+++ b/www-apps/trickster/trickster-1.1.5.ebuild
@@ -7,9 +7,7 @@ inherit go-module systemd
DESCRIPTION="Dashboard Accelerator for Prometheus"
HOMEPAGE="https://github.com/tricksterproxy/trickster"
-VENDOR_URI="https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
-SRC_URI="https://github.com/tricksterproxy/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${VENDOR_URI}"
+SRC_URI="https://github.com/tricksterproxy/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,10 +19,7 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
-src_prepare() {
- default
- mv ../vendor .
-}
+ RESTRICT="test"
src_compile() {
set -- go build -mod vendor ./cmd/trickster
@@ -34,8 +29,8 @@ src_compile() {
src_install() {
dobin ${PN}
-dodoc -r conf docs/*
- systemd_dounit conf/trickster.service
+dodoc -r docs/*
+ systemd_dounit deploy/systemd/trickster.service
insinto /etc/trickster
doins "${FILESDIR}"/${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}