summaryrefslogtreecommitdiff
path: root/www-apps/roundup
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/Manifest2
-rw-r--r--www-apps/roundup/roundup-2.3.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
index 7cf65a2b5791..5214058d9b95 100644
--- a/www-apps/roundup/Manifest
+++ b/www-apps/roundup/Manifest
@@ -1,3 +1,5 @@
DIST roundup-2.2.0.tar.gz 3722236 BLAKE2B f9f36ff2a49c769dcce38dd59fd88825cb3a6560fbfc2a7bbf6d2abf1388bb328da5aa7de2934ae2469163bb4f125b4438b07f1eff9082458768012b4eda7687 SHA512 dbaf7c4a5e7fb75f0e401f39962c8f5a3b088036a0f2c9efb2910f3941df35df6c345c2051c37cbdcc9a2049d82d09bcb4e15b368f8c4c77fa4b4bf80c6dc844
+DIST roundup-2.3.0.tar.gz 3880745 BLAKE2B a6ed278352a91893cd5706b8e5c9fcbed76fc35364cb3709371187ba27b459efa4676ed8a342c937fcd2b637f21714379acdec21631e6c9012ab6a8bf3cebfcd SHA512 83c659ce8d268f4f7f16f10731371ed6320564635e2620e2502e600c4ddbcae92f5c46722a33c66aceef5a8af99f5c556bce5512f03b97ff0cfb88e8bafe7cb6
EBUILD roundup-2.2.0.ebuild 1700 BLAKE2B ee8d632acfcff7dba1e41d20702299c1d5a5b754e009105c04dec3c895592f80b27b01accbb20b2699acd002f9f54acbd59fde62b9bc1f470c840094af1a3a05 SHA512 9257666d72e1907feb0de3d8109f0a9d35f9c79b38e09339be0b70a7ac0acd3683a0f44974899e0f4c81ef1c6f6723b69ccba8abe698fec47dfef29dd59757ae
+EBUILD roundup-2.3.0.ebuild 2526 BLAKE2B b6fd2bf37c9a6b78a5e0434db0ae6aae210cfcc7204582bc99b9f07d9b0a5a2c751f3093d9fe383bdd11102f2d324d285b21fa7931caaf0a5812b8f6dc1804c3 SHA512 78e96d297283c5e228145a09dbc920594aa39fea0b5a29bf6b55256d92ec48763a5ba57beecaf48b38c28113569dedbd5ae560d123e45f36f979f5512a958712
MISC metadata.xml 859 BLAKE2B 4ed7bcbc75c9efb585273835f8d50f933e79e6d67c982e596aa320fa87b533136eb8040ff3df94ac4ee045bb6dab8aad5c8bfd0c5df764425a2c43b015753f6b SHA512 3ec9884582ea8ad43a9210519c069ef87e1e2ae55b4f2d11c3f97de8add7b3df1ec31b0651aa96163564159febe58b6dc174b94782c6a618d090d67b7530547e
diff --git a/www-apps/roundup/roundup-2.3.0.ebuild b/www-apps/roundup/roundup-2.3.0.ebuild
new file mode 100644
index 000000000000..e8fc8857ed1f
--- /dev/null
+++ b/www-apps/roundup/roundup-2.3.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="https://roundup.sourceforge.io https://pypi.org/project/roundup/"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown test"
+
+RDEPEND="
+ jinja? ( dev-python/jinja[${PYTHON_USEDEP}] )
+ markdown? (
+ || (
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/mistune[${PYTHON_USEDEP}]
+ )
+ )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg:0[${PYTHON_USEDEP}] )
+ pyjwt? ( dev-python/pyjwt[${PYTHON_USEDEP}] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ tz? ( dev-python/pytz[${PYTHON_USEDEP}] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[${PYTHON_USEDEP}] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,${PYTHON_USEDEP}] )
+"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tries to connect to non-running server
+ test/test_liveserver.py::TestPostgresWsgiServer
+ test/test_sqlite.py::sqliteSessionTest
+ test/test_sqlite.py::sqliteSpecialActionTestCase::testInnerMain
+ # automagic, assumes a postgresql server is available
+ test/test_config.py::TrackerConfig::testLoadSessionDbRedis
+
+ # upstream issue: https://issues.roundup-tracker.org/issue2551335
+ test/test_templating.py::Markdown2TestCase::test_markdown_hyperlinked_url
+ # upstream issue: https://issues.roundup-tracker.org/issue2551336
+ test/test_templating.py::Markdown2TestCase::test_string_markdown_link_item
+)
+
+python_install() {
+ distutils-r1_python_install
+ if [[ -d "${ED}"/usr/share ]]; then
+ rm -r "${D}$(python_get_sitedir)"/usr
+ else
+ mv "${D}$(python_get_sitedir)"/usr/share "${ED}"/usr/ || die
+ dodir /usr/share/doc/${PF}
+ mv "${ED}"/usr/share/doc/${PN}/html "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${PN} || die
+ rmdir "${D}$(python_get_sitedir)"/usr || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}"/usr/share/roundup -name __pycache__ -type d -exec rm -r {} +
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}