summaryrefslogtreecommitdiff
path: root/www-apps/openwebstats/openwebstats-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/openwebstats/openwebstats-1.1.ebuild')
-rw-r--r--www-apps/openwebstats/openwebstats-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/openwebstats/openwebstats-1.1.ebuild b/www-apps/openwebstats/openwebstats-1.1.ebuild
new file mode 100644
index 000000000000..4aff79996bfd
--- /dev/null
+++ b/www-apps/openwebstats/openwebstats-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit webapp
+
+DESCRIPTION="PHP stats application that reads Apache log files and imports the data to a MySQL database"
+HOMEPAGE="http://openwebstats.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+
+ ## Main application
+ cp -r . "${D}${MY_HTDOCSDIR}"
+ cp "${FILESDIR}/config.php" "${D}${MY_HTDOCSDIR}/"
+
+ ## Docs installed, remove unnecessary files
+ rm -f "${D}${MY_HTDOCSDIR}/README"
+ rm -f "${D}${MY_HTDOCSDIR}/CHANGELOG"
+
+ # Database creation
+ webapp_sqlscript mysql "${D}${MY_HTDOCSDIR}/openwebstats.sql"
+
+ # Postinstall instructions
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}