summaryrefslogtreecommitdiff
path: root/www-apps/drraw/drraw-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/drraw/drraw-2.0.1.ebuild')
-rw-r--r--www-apps/drraw/drraw-2.0.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/www-apps/drraw/drraw-2.0.1.ebuild b/www-apps/drraw/drraw-2.0.1.ebuild
deleted file mode 100644
index e71913547cb4..000000000000
--- a/www-apps/drraw/drraw-2.0.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit webapp
-
-DESCRIPTION="drraw is a simple web based presentation front-end for RRDtool"
-HOMEPAGE="http://web.taranis.org/drraw"
-SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="ppc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/perl-5.6
- dev-perl/CGI
- >=net-analyzer/rrdtool-1.0.47"
-
-need_httpd_cgi
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s|/usr/local/bin/perl|/usr/bin/perl|" drraw.cgi
- sed -i \
- -e "s|/somewhere/drraw/saved|/tmp|" \
- -e "s|/somewhere/drraw/tmp|/tmp|" \
- drraw.conf
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc CHANGES INSTALL README.EVENTS WISHLIST
- rm CHANGES INSTALL README.EVENTS WISHLIST
-
- insinto "${MY_CGIBINDIR}"
- doins drraw.conf
-
- exeinto "${MY_CGIBINDIR}"
- doexe drraw.cgi
-
- insinto "${MY_ICONSDIR}"
- doins icons/*.gif
-
- webapp_configfile "${MY_CGIBINDIR}"/drraw.conf
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}