summaryrefslogtreecommitdiff
path: root/virtual/wireguard/wireguard-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/wireguard/wireguard-1.ebuild')
-rw-r--r--virtual/wireguard/wireguard-1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/virtual/wireguard/wireguard-1.ebuild b/virtual/wireguard/wireguard-1.ebuild
new file mode 100644
index 000000000000..4fa639117c92
--- /dev/null
+++ b/virtual/wireguard/wireguard-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+module +tools"
+
+RDEPEND="
+ tools? ( net-vpn/wireguard-tools )
+ module? ( net-vpn/wireguard-modules )
+"
+
+pkg_postinst() {
+ ewarn
+ ewarn "This package, ${CATEGORY}/${PN}, has been deprecated, in favor of explicitly"
+ ewarn "merging the tools and the modules separately. You may accomplish this by"
+ ewarn "running:"
+ ewarn
+ ewarn " emerge -nO net-vpn/wireguard-tools net-vpn/wireguard-modules"
+ ewarn " emerge -C virtual/wireguard"
+ ewarn
+ ewarn "When Linux 5.6 comes out, net-vpn/wireguard-modules itself will be deprecated,"
+ ewarn "with its functionality having moved directly into Linux."
+ ewarn
+}