summaryrefslogtreecommitdiff
path: root/virtual/rust/rust-1.76.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/rust/rust-1.76.0.ebuild')
-rw-r--r--virtual/rust/rust-1.76.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.76.0.ebuild b/virtual/rust/rust-1.76.0.ebuild
new file mode 100644
index 000000000000..187391b93274
--- /dev/null
+++ b/virtual/rust/rust-1.76.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"