summaryrefslogtreecommitdiff
path: root/virtual/python-funcsigs/python-funcsigs-2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-funcsigs/python-funcsigs-2.ebuild')
-rw-r--r--virtual/python-funcsigs/python-funcsigs-2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-funcsigs/python-funcsigs-2.ebuild b/virtual/python-funcsigs/python-funcsigs-2.ebuild
new file mode 100644
index 000000000000..97b1594ab648
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.6 variant)"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/funcsigs-1[${PYTHON_USEDEP}]' python2_7 python3_{3,4,5} pypy{,3} )"