summaryrefslogtreecommitdiff
path: root/virtual/python-cffi/python-cffi-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-cffi/python-cffi-1.ebuild')
-rw-r--r--virtual/python-cffi/python-cffi-1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-cffi/python-cffi-1.ebuild b/virtual/python-cffi/python-cffi-1.ebuild
new file mode 100644
index 000000000000..46dd20bde9dc
--- /dev/null
+++ b/virtual/python-cffi/python-cffi-1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python cffi package"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# built-in in PyPy and PyPy3
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')"