summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10151 -> 10149 bytes
-rw-r--r--sys-process/usbtop/Manifest4
-rw-r--r--sys-process/usbtop/usbtop-1.0.ebuild29
-rw-r--r--sys-process/usbtop/usbtop-1.0_p20220419.ebuild32
4 files changed, 34 insertions, 31 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index a4b9afad3d1b..bb325c35603a 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/usbtop/Manifest b/sys-process/usbtop/Manifest
index 464c1b07d87a..8f63d37d31be 100644
--- a/sys-process/usbtop/Manifest
+++ b/sys-process/usbtop/Manifest
@@ -1,3 +1,3 @@
-DIST usbtop-1.0.tar.gz 626770 BLAKE2B 4f14e1e8d926ce7f6ffd1a276871d7d9072979d844a55e477c402bcac343a3cc14faebbfd3886b386a48b01399bcb748fb843453a0eee48b8e09578841eab356 SHA512 bc2003c1085fae238d99347bbf3caa1da7e44aa8f5b07abbde3f96b4124b301bbbc896f7b5e341665db1cdba44a59752884e3b9fe3a6104ef804aa94c510a5c0
-EBUILD usbtop-1.0.ebuild 657 BLAKE2B 54c11c3e58a2ac0773dcf9e4f9836b4672a25bd31b1d65693c476648b3ca7275c698cf4a99287b574ca2603d45a33ff14417676a479c5cca350e869ae2b9b035 SHA512 53fdd01fde21c04426f737e4e55ec2cf77e9f490c47f79b85ed511505b1a48943643ae913c6d3dbb02d8d4698c790adf3e33f382b7b2f1fc37c5a3c9c11a15cd
+DIST usbtop-1.0_p20220419.tar.gz 627690 BLAKE2B 6ba2e5895674383ae4e83abd6907c53e33515bca2cbb1d67063ba1a7429446a67a6b94b3008e830ffee1d620669789e7ececfb5961b2946aac1353599c927e3e SHA512 94a890b94b37b0c7e818be7e7ada4b51e19d51bf7ca7e4b66632532698a04ff1bb05c51c5cb27740b036a98d193024f15249feed4f4044029b737d0609fbb011
+EBUILD usbtop-1.0_p20220419.ebuild 821 BLAKE2B 5938237d9ae1c6432ca0eecb2e7c20921925a77fa51b0055b015c5a8551871accd04a2825c2027566a7679501303fd9470546fff7ea47a144d63622a9012a073 SHA512 80a123546830074263756f56f2237f54938aed63f88a29417f4b28af3b9e11678ee38c21b54faae48d28558e2499bf956df3bad16ac1b9117ec278047c8eb3f3
MISC metadata.xml 327 BLAKE2B 87ae54c37ceb64edd74580f89ab17a0834ae76b28e6c98db715dd767cdc16eae1a98495bd0d947fa4edda20febf16ae6073c247a0c37c03304ff35071e57ab72 SHA512 f1c443245158c324920fcef5c9954b13de3878eefc072b454f57bb98be0222001f0571e5b52c1853316f360f1e6b91b01c4555c8a17d7fb54178589c6ee5cb1a
diff --git a/sys-process/usbtop/usbtop-1.0.ebuild b/sys-process/usbtop/usbtop-1.0.ebuild
deleted file mode 100644
index 7b0e14747291..000000000000
--- a/sys-process/usbtop/usbtop-1.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake linux-info
-
-DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
-HOMEPAGE="https://github.com/aguinet/usbtop"
-SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
-
-DEPEND="net-libs/libpcap:=[usb]
- dev-libs/boost:="
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-release-${PV}"
-
-pkg_setup() {
- linux-info_pkg_setup
- if linux_config_exists; then
- CONFIG_CHECK="~USB_MON"
- check_extra_config
- fi
-}
diff --git a/sys-process/usbtop/usbtop-1.0_p20220419.ebuild b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
new file mode 100644
index 000000000000..609eff05f6dc
--- /dev/null
+++ b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+#SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="b9a26bd22b91b84bd72906c6501e61df7b13f3d6"
+SRC_URI="https://github.com/aguinet/usbtop/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap[usb]"
+DEPEND="${RDEPEND}
+ dev-libs/boost:="
+
+#S="${WORKDIR}/${PN}-release-${PV}"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}