summaryrefslogtreecommitdiff
path: root/sys-process/watchpid/watchpid-0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/watchpid/watchpid-0.1-r2.ebuild')
-rw-r--r--sys-process/watchpid/watchpid-0.1-r2.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/sys-process/watchpid/watchpid-0.1-r2.ebuild b/sys-process/watchpid/watchpid-0.1-r2.ebuild
index 93e680eadf24..e190ab0d69d9 100644
--- a/sys-process/watchpid/watchpid-0.1-r2.ebuild
+++ b/sys-process/watchpid/watchpid-0.1-r2.ebuild
@@ -1,28 +1,23 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="Watches a process for termination"
-SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
HOMEPAGE="http://www.codepark.org/"
-KEYWORDS="amd64 ppc x86"
+SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
-DOCS=( README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
multilib_src_configure() {
+ tc-export CC
ECONF_SOURCE="${S}" econf
}
-
-src_compile() {
- multilib-minimal_src_compile
-}
-
-src_install() {
- multilib-minimal_src_install
-}