summaryrefslogtreecommitdiff
path: root/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/usbtop/usbtop-1.0_p20220419.ebuild')
-rw-r--r--sys-process/usbtop/usbtop-1.0_p20220419.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/usbtop/usbtop-1.0_p20220419.ebuild b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
new file mode 100644
index 000000000000..609eff05f6dc
--- /dev/null
+++ b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+#SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="b9a26bd22b91b84bd72906c6501e61df7b13f3d6"
+SRC_URI="https://github.com/aguinet/usbtop/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap[usb]"
+DEPEND="${RDEPEND}
+ dev-libs/boost:="
+
+#S="${WORKDIR}/${PN}-release-${PV}"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}