summaryrefslogtreecommitdiff
path: root/sys-process/numad/numad-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/numad/numad-9999.ebuild')
-rw-r--r--sys-process/numad/numad-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
new file mode 100644
index 000000000000..c44a0fea5cb3
--- /dev/null
+++ b/sys-process/numad/numad-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ inherit git-2
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86 -arm -s390"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}