summaryrefslogtreecommitdiff
path: root/sys-process/numactl/numactl-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/numactl/numactl-9999.ebuild')
-rw-r--r--sys-process/numactl/numactl-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
index 312ab570210b..6bcda4fcddba 100644
--- a/sys-process/numactl/numactl-9999.ebuild
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
@@ -26,6 +26,11 @@ PATCHES=(
src_prepare() {
default
+
+ # lto not supported yet
+ # gcc-9 with -flto leads to link failures: #692254
+ filter-flags -flto*
+
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources
@@ -41,7 +46,7 @@ multilib_src_compile() {
multilib_src_test() {
if multilib_is_native_abi ; then
- if [ -d /sys/devices/system/node ]; then
+ if [[ -d /sys/devices/system/node ]] ; then
einfo "The only generically safe test is regress2."
einfo "The other test cases require 2 NUMA nodes."
emake regress2
@@ -54,12 +59,12 @@ multilib_src_test() {
multilib_src_install() {
emake DESTDIR="${D}" \
install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
- find "${ED%/}"/usr/ -name libnuma.la -delete || die
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
}
multilib_src_install_all() {
local DOCS=( README.md )
einstalldocs
# delete man pages provided by the man-pages package #238805
- rm -r "${ED%/}"/usr/share/man/man[25] || die
+ rm -r "${ED}"/usr/share/man/man[25] || die
}