summaryrefslogtreecommitdiff
path: root/sys-process/numactl/numactl-2.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/numactl/numactl-2.0.12.ebuild')
-rw-r--r--sys-process/numactl/numactl-2.0.12.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-process/numactl/numactl-2.0.12.ebuild b/sys-process/numactl/numactl-2.0.12.ebuild
index 382d2e6496e8..f97df3e27045 100644
--- a/sys-process/numactl/numactl-2.0.12.ebuild
+++ b/sys-process/numactl/numactl-2.0.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
@@ -13,7 +13,7 @@ if [[ "${PV}" == 9999 ]] ; then
else
SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
# ARM lacks the __NR_migrate_pages syscall.
- KEYWORDS="~amd64 -arm arm64 ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
+ KEYWORDS="amd64 -arm arm64 ia64 ~mips ppc ppc64 x86 ~amd64-linux"
fi
LICENSE="GPL-2"
@@ -26,6 +26,11 @@ PATCHES=(
src_prepare() {
default
+
+ # lto not supported yet
+ # gcc-9 with -flto leads to link failures: #692254
+ filter-flags -flto*
+
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources