summaryrefslogtreecommitdiff
path: root/sys-process/lsof/lsof-4.99.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/lsof/lsof-4.99.0.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.99.0.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/sys-process/lsof/lsof-4.99.0.ebuild b/sys-process/lsof/lsof-4.99.0.ebuild
index c94a98abca1d..5a38a82c4076 100644
--- a/sys-process/lsof/lsof-4.99.0.ebuild
+++ b/sys-process/lsof/lsof-4.99.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
MY_P="${P/-/_}"
DESCRIPTION="Lists open files for running Unix processes"
HOMEPAGE="https://github.com/lsof-org/lsof"
@@ -26,6 +28,17 @@ BDEPEND="
# Needs fixing first for sandbox
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.98.0-fix-clang-version-parser.patch
+)
+
+# TODO: drop this block, "inherit autotools" and clang-version-parser patch after 4.99.3
+# https://github.com/lsof-org/lsof/pull/306
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_with rpc libtirpc)
@@ -39,6 +52,11 @@ src_compile() {
emake DEBUG="" all
}
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
pkg_postinst() {
if [[ ${CHOST} == *-solaris* ]] ; then
einfo "Note: to use lsof on Solaris you need read permissions on"