summaryrefslogtreecommitdiff
path: root/sys-process/glances/glances-3.4.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/glances/glances-3.4.0.3.ebuild')
-rw-r--r--sys-process/glances/glances-3.4.0.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-process/glances/glances-3.4.0.3.ebuild b/sys-process/glances/glances-3.4.0.3.ebuild
index acae2879ed60..c6302cc70e1c 100644
--- a/sys-process/glances/glances-3.4.0.3.ebuild
+++ b/sys-process/glances/glances-3.4.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,7 +36,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.4.0.3-disable-update-check.patch"
)
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
distutils_enable_sphinx docs --no-autodoc
pkg_setup() {
@@ -56,6 +56,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_test() {
+ "${EPYTHON}" unitest.py || echo "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
# add an intended file from original data set from setup.py to DOCS
local DOCS=( README.rst CONTRIBUTING.md conf/glances.conf )