summaryrefslogtreecommitdiff
path: root/sys-process/glances/glances-3.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/glances/glances-3.3.0-r1.ebuild')
-rw-r--r--sys-process/glances/glances-3.3.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-process/glances/glances-3.3.0-r1.ebuild b/sys-process/glances/glances-3.3.0-r1.ebuild
index 84279372149c..7b155a7902b5 100644
--- a/sys-process/glances/glances-3.3.0-r1.ebuild
+++ b/sys-process/glances/glances-3.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,7 +35,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.2.5-disable-update-check.patch"
)
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
distutils_enable_sphinx docs --no-autodoc
pkg_setup() {
@@ -55,6 +55,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_test() {
+ "${EPYTHON}" unitest.py || die "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
# add an intended file from original data set from setup.py to DOCS
local DOCS=( README.rst CONTRIBUTING.md conf/glances.conf )