summaryrefslogtreecommitdiff
path: root/sys-process/ctop/ctop-0.7.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/ctop/ctop-0.7.7.ebuild')
-rw-r--r--sys-process/ctop/ctop-0.7.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-process/ctop/ctop-0.7.7.ebuild b/sys-process/ctop/ctop-0.7.7.ebuild
new file mode 100644
index 000000000000..bec6ba5b3f9f
--- /dev/null
+++ b/sys-process/ctop/ctop-0.7.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Top-like interface for container-metrics"
+HOMEPAGE="https://ctop.sh https://github.com/bcicen/ctop"
+SRC_URI="https://github.com/bcicen/ctop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ emake VERSION="${PV}" BUILD="${PVR}" build
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}